
GarageBand Step-by-Step 



	 For personal use only. Not for resale.

Contents

Adding Loops to a GarageBand Project. .  .  .  .  . 2

Using Musical Typing. .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 6

Editing with the Track Editor. .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 9

Sharing a GarageBand Song to iTunes. .  .  .  .  . 11

Recording a Podcast. .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 13

Sharing a Podcast To iWeb . .  .  .  .  .  .  .  .  .  .  .  .  .  .  20

Using Magic GarageBand . .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 22



GarageBand Step-by-Step

For personal use only. Not for resale.	 1

GarageBand Step-by-Step

GarageBand makes it easy to create your own music, even if you’re not a 
musician. By using GarageBand’s built-in instruments in a wide range of genre 
and performance styles, you can create original compositions for movies, 
slideshows, and podcasts—anywhere a melody would be welcome. 

This step-by-step guide is meant to be used with the videos on the DVD. By 
using both, you’ll quickly learn how to create and use your own music in your 
own lessons. The tutorials here will lead you through creating specific parts of 
the ocean field trip project.
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Adding Loops to a GarageBand Project
One easy way to create a song is to build it by using loops—prerecorded snippets of music 
that you can string together in a project.

To add loops to a project:

Open GarageBand by clicking its icon in the dock (or double-clicking its icon in  1	
the Finder).

The GarageBand ‘08 introduction window opens. (If you’ve already used GarageBand,  
the last project you worked on will open instead.) 

   

The GarageBand introduction 
window lets you choose the 
type of project you want to 
create—or open an existing 
project.

If a GarageBand project is already open, select File -> New, or type Command-N.2	

A New Project dialog box appears. 

   

Give your project a name in this dialog 
box, change its tempo and key if you 
want to, and then find a place to save it.

Adding Loops to a  GarageBand Project
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In the New Project dialog box, give your song a name. Before you navigate to where you 3	
want to save the project, you can also adjust the tempo or the key signature and key, and 
then click Create.

   

We’ve named our project “Field 
Trip Music Score” to use with 
the images from our ocean 
field trip.

The project is saved and a new GarageBand window opens. 

   

A fresh GarageBand project 
contains a Grand Piano 
Software Instrument.

You’ll notice this project has a Grand Piano instrument already in it.

Adding Loops to a  GarageBand Project
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Select the Grand Piano instrument, then choose Track -> Delete Track, or press  4	
Command-delete. Then close the Keyboard window by clicking its close button.

The Grand Piano instrument is removed from the project. We’re deleting it here so we can 
learn how to add a track in the next section. 

   

By deleting the default Grand 
Piano instrument, we’re left 
with a blank slate on which to 
build.

In the lower-left corner of the window, click the button with an eye on it—the Loop 5	
Browser button.

The Loop Browser slides up from the bottom of the window. 

   

In the lower-left corner, the 
Loop Browser has over 25 
categories of loops. 

Click the kind of instrument you want to add to your project.6	

The right side of the Loop Browser fills with a list of loops. 

   

Each category shows a list of 
available loops—and this list 
varies, depending on which 
Jam Packs you’ve installed.

Adding Loops to a  GarageBand Project
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From the list on the right, drag the loop you want to use onto the project.7	

The loop appears in the project window. 

   

When you drag a loop onto 
your project, it appears as a 
new track. Here, we’ve chosen a 
Southern-style drum beat.

Drag the upper-right corner of the loop to the right for several measures.8	

The cursor turns into a loop icon and as you drag, the loop is repeated. 

   

Drag the upper-right corner  
of the loop to make it longer. 
It’ll repeat the loop to the point 
where you dragged it.

In the Loop Browser, click Reset.9	

The Loop Browser resets itself, and you’re ready to select another loop. 

   
After you reset the loops, 
the list to the right clears. 

Repeat Steps 6-9 to add a bass loop and a guitar loop to your project, making them equal 
in length. By using built-in GarageBand Loops, you’ve created a simple, short song.

Adding Loops to a  GarageBand Project
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Using Musical Typing
Although you can easily create a song using nothing but Apple Loops, you can also add to a 
song by recording a MIDI instrument—even if you don’t have a MIDI device. Through Musical 
Typing, you can use your Mac’s keyboard to play an instrument in a GarageBand track.

To record a track using Musical Typing:

Open the project you created in the previous step-by-step tutorial, and then click the + button.1	

A pane slides down asking you to choose a Software Instrument Track or a Real Instrument track. 

   

When you add an instrument, 
you can choose to add a MIDI-
based software instrument or a 
real instrument. 

Select Software Instrument Track, then click Create.2	

A Grand Piano instrument is added to the project, and the Track Info browser appears on the right. 

   

The Track Info browser lets you 
change a selected instrument 
by browsing through a 
categorized list. 

Using Musical Typing
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In the Track Info browser, first select the type of instrument you’d like to use instead of the 3	
Grand Piano, and then select the specific instrument you want to add.

The Grand Piano instrument changes into the instrument you selected. 

   

When you select an instrument 
in the Track Info browser, the 
current track plays that new 
instrument’s sound.

Select Window -> Musical Typing (or type Command-Shift-K).4	

The Musical Typing window appears. 

   

The Musical Typing window 
lets you use your computer 
keyboard to play the selected 
instrument. 

Select Control -> Count In (or type Command-Shift-U), then, in the lower portion of the 5	
window, click the Record button. 

   
Click the red Record button to 
start your recording. 

GarageBand will count one measure, and then begin recording the track. 

Using Musical Typing
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Using the Musical Typing keyboard, play the instrument. GarageBand will record until you 6	
click the Record button again, or press the spacebar.

The recorded track is now part of the GarageBand project. Be sure to save your changes.

   

Our newly recorded synth track 
appears in the project after 
recording.

Using Musical Typing
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Editing with the Track Editor
Not every performance is a keeper. Fortunately, GarageBand lets you select those that are 
pretty close.

To edit a MIDI track:

Open the project with the recorded MIDI track that you created in the previous tutorial, 1	
then double-click the recorded region.

The Track Editor slides up from the bottom of the window. This is a MIDI track, so the 
musical notes are represented by bars. 

   

When you edit a Software 
Instrument track, its notes 
appear as bars in the editing 
section. 

Using your mouse, you can edit the MIDI notes: 2	

   

Here, we’re dragging the right 
edge of a note to make it 
longer. 

• To change pitch, drag a note up or down on the grid 

• To make a note longer or shorter, drag the edge of a note

• To delete a note, select it, then press Delete

Editing with the Track Editor
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Choose the type of note from the Enhance Timing popup menu, then slide the Enhance 3	
Timing slider to the right to nudge notes into more accurate timing.

As you slide the slider, notes move to the nearest beat. 

   

By sliding the Enhance 
Timing slider, you can move 
notes to more regular timing. 
Don’t do too much, though, 
or the playback will sound 
mechanical.

Editing with the Track Editor
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Sharing a GarageBand Song to iTunes
Once you’ve finished creating your song in GarageBand, you can share it so that applications 
such as iMovie and iPhoto can use it, or you can post it to your web site, burn it to CD, or even 
email it. Here, we’ll show you how to send a song to iTunes.

To share a GarageBand song with iTunes:

Open the GarageBand project you want to share.1	

Select Share -> Send Song to iTunes2	

A pane slides down, asking you for details regarding your song. 

   

Before you send a song to 
iTunes, you’ll need to provide 
some information. Your song 
may already have some of 
these fields filled in. 

In the pane, fill in the following text fields: 3	

• iTunes Playlist

• Artist Name

• Composer Name

• Album Name

   

We’ve provided a playlist name, 
artist name, composer name, 
and album name for our field 
trip song. 

Sharing a GarageBand Song to iTunes
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In the settings controls, do the following: 4	

   

For our field trip music, we’ve 
chosen the AAC Encoder 
and set the audio settings to 
Higher Quality. Since the song 
is short, the file’s size won’t be 
increased too much.

• Check the Compress checkbox

• In the “Compress Using” popup menu, select your preferred encoder

• In the “Audio Settings” popup menu, select the quality level you’d like for your song

The song is sent to iTunes in its own playlist, and it begins to play. 

   

When a song is sent to iTunes 
from GarageBand, it appears 
in its own playlist and begins 
playing automatically.

Sharing a GarageBand Song to iTunes
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Recording a Podcast
Now that we know how to create a song in GarageBand, let’s use it to enhance a lesson 
through a podcast.

To create a podcast with GarageBand:

Open GarageBand, and close any currently open projects. The new project window 1	
appears. Click “Create New Podcast Episode.”

   

“Create New Podcast Episode” 
gives you a starting point 
tailored for podcasts.

A Save window appears.

In the Save As field, type the name for your podcast, then click Create.2	

A new GarageBand podcast project appears. 

   

A fresh podcast episode opens 
with two voice tracks, a music 
track, and a pictures track. The 
media browser to the right lets 
you add music and pictures. 

Recording a Podcast
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In the next two steps, we’re going to show you how to use an external microphone  3	
to record a podcast. If you’re using a built-in microphone, skip to Step 5. Choose 
GarageBand -> Preferences.

The GarageBand Preferences window opens. 

   

The GarageBand preferences 
window lets you control how 
GarageBand behaves. Change 
settings by clicking one of the 
category buttons at the top, 
then make your changes.

At the top of the window, click Audio/MIDI, then select the audio input and output 4	
sources you want to use while recording. Be sure your microphone is plugged in, or it may 
not show up in the source list. 

   

The Audio/MIDI preferences 
let you set input and output 
devices, and you can also 
control how your MIDI devices 
work with GarageBand.

GarageBand asks if you really want to change the audio driver. Click Yes.

Recording a Podcast



GarageBand Step-by-Step

For personal use only. Not for resale.	 15

Close the preferences window and select the male or female voice track you’d like to use. 5	
Next, click the Record button and begin reading your script.

GarageBand records your voice as you read. 

   

When you record your voice, 
a graphical representation of 
your recording appears in the 
track—as well as in the bottom 
section of the window.

Press the spacebar to stop the recording. You can press Record to continue recording, and 6	
press the spacebar again to stop. 

   

If you’re recording in several 
takes, you can start your next 
take by simply placing the 
playhead where you’d like to 
start, then clicking the Record 
button.

Recording a Podcast
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In the Media Browser at the right, click Audio, then click a playlist.7	

A list of songs will appear at the bottom of the Media Browser. 

   

The Media Browser gives you 
quick access to all of your 
iTunes audio—including the 
song we created for our field 
trip project. 

Drag the song from the Media Browser onto the Jingles track. If you don’t have any songs 8	
in your iTunes library, you can use Jingles from the Loop Browser, as you did in “Adding 
Loops to a GarageBand Project.”

The song is loaded into the track. 

   

To use a song in a podcast, 
drag it from the Media Browser 
onto the Jingles track—here, 
we’re using our original song 
created for the field trip.

Recording a Podcast
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Click Photos in the Media Browser, then click an album.9	

The photos from the album load in the lower portion of the Media Browser. 

   

The Media Browser also gives 
you quick access to your iPhoto 
library—including any albums 
you’ve created—to create an 
enhanced podcast. 

Drag the desired album onto the Podcast Track. 10	

   

Drag an album onto the 
Podcast Track to embed the 
photos in the podcast.

The photos are added to the project. 

Recording a Podcast
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Select the Podcast Track, then drag a photo from the Media Browser to the Episode 11	
Artwork area of the window. If the Track Editor with the chapters is not visible, click the 
View/Hide the Track Editor button, which is the scissor button in the lower-left portion of 
the screen. Alternatively, you can choose Control -> Show Editor, or type Command-E. 

   

To give your podcast some 
more visual flair, drag a photo 
onto the Episode Artwork area 
of the window. You can also 
drag a Keynote slide onto this 
area.

The episode artwork is added to the project. 

In the Chapter area at the bottom of the screen, type in the chapter titles and add URL 12	
titles and hyperlinks by double-clicking the text field in the corresponding chapter, then 
typing the text. 

   

Name your podcast chapters, 
and provide any URLs for more 
information. Here, we’re linking 
to a Wikipedia article on sea 
anemones.

Recording a Podcast
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If needed, move the elements back and forth on the timeline in the various tracks by 13	
dragging an element. You can resize or move photo elements in a track to ensure they 
synchronize with your script, or move voice or music tracks to a specific point in time for 
just the right effect.

   

You can move tracks around to 
get the timing just right. Here, 
we’re lengthening a photo in 
the timeline to make it display 
longer during the musical 
introduction. 

Recording a Podcast
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Sharing a Podcast To iWeb
Most likely, if you’ve created a podcast, you’ll want to share it using the Internet.

To share a GarageBand podcast using iWeb:

Open the podcast you want to share in GarageBand, then select Share -> Send Podcast to iWeb 1	

A settings pane slides down. 

   

When sending a podcast 
to iWeb, you’ll be asked to 
specify audio compression and 
settings, as well as whether 
you’d like to resize artwork, 
before you can proceed. 

In the settings pane do the following:2	

• In the “Compress Using” popup menu, select an encoder

• In the “Audio Settings” popup menu, select a quality setting

• Ensure that the checkbox in the “Publish Podcast” area is checked

• Click “Share”	

GarageBand prepares the podcast, opens iWeb, and sends the podcast to it. (Note: This 
assumes you have a .Mac account.) 

   

When your podcast opens in 
iWeb, the podcast page will 
have placeholder text you’ll 
need to edit. 

Sharing a Podcast to iWeb
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Double-click the text areas in the podcast window, and replace the placeholder text with 3	
your own text. 

   

Edit your placeholder podcast 
text by double-clicking it and 
typing the text you want to 
use.

Publish the podcast using one of the publishing options under the File menu.4	

   

Choose one of the publishing 
options from the File menu to 
publish your site. Here, we’re 
publishing it to a .Mac site.

The podcast publishes according to your iWeb settings.

You can also use GarageBand’s Share menu to send your podcast to iTunes as a song or even 
a ringtone for iPhone.

Sharing a Podcast to iWeb
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Using Magic GarageBand
If you don’t know a lot about music, but you’d still like to create a song, Magic GarageBand 
can help. With it, you can bring the band together and let GarageBand generate the song.

To use Magic GarageBand:

Open GarageBand, and close any currently open projects. The new project window 1	
appears. Click Magic GarageBand.

The Magic GarageBand project window opens. 

   

Magic GarageBand lets you 
choose from nine musical 
genres to kick-start your 
project.

In the Genre row at the bottom, click the kind of music you want to create, then click the 2	
Play button. 

A sample of the music plays. 

   

The Play button lets you 
preview a genre before 
committing to it.

Using Magic GarageBand
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Click the Play button again to stop the sample, then click the Audition button. 3	

The curtains part, revealing a set of instruments. 

   

Once you’ve chosen a genre, 
a set of instruments appears 
on stage.

Click one of the instruments on stage. 4	

A selection of alternative instruments for this slot appears at the bottom. 

   

Magic GarageBand lets you 
swap out instruments for a 
given slot—so that you get the 
sound you want. Here, we’ve 
selected the bass so that we 
can swap it for another one.

Using Magic GarageBand
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Click the instrument you want to use in that slot, and then repeat for each instrument you 5	
want to change. 

   

Selecting a different instrument 
in the row below replaces it in 
the project.

Click Create Project.6	

GarageBand creates a project using your settings. 

   

The final result of Magic 
GarageBand is a standard 
project, complete with 
instruments already set up for 
you. 

Now you can edit your pre-built song to your liking. 

Using Magic GarageBand
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